Lemmy Support - Privacy Community
How do I promote a user to be an admin?
I can’t see anywhere in the UI to be able to promote a user to be an administrator. How do I do this?

Correct Spelling of a Community
I just built Lemmy on a Linode VPS using Yunohost. I started creating communities but I misspelled the name of one of them. I can't see where I can edit that as an Admin. I'm really wondering if my admin console has all the feature, because I can't see how to make a user and admin either. It all seems really bare in terms of what can be done. Anyway, first things first, how do I correct the name of a community?

How can I visit the main page of another instance?
To see a community from another instance I can write ``` https://lemmy.ml/c/community@instance ``` For example ``` https://lemmy.ml/c/linux@heapoverflow.ml ``` How can I visit the main page instead of a community from another instance?

  • Ada
  • edit-2
Formatting links to remote communities?
How do I format a link to a remote lemmy community that allows someone to subscribe to it directly from their own instance? An example of such a post is here https://lemmy.blahaj.zone/post/4711. This is a post made for a community on mander.xyz, posted to lemmy.ml and viewed through my instance blahaj.zone. Whichever instance you view it on, the link formats so that you can subscribe to it directly from the instance you are viewing it on. I’ve tried using /c/communityname formatting, but that doesn’t seem to work. @sal@mander.xyz

Can’t post pictures from Friendica
When I try to post images/pictures from my Friendica account to a Lemmy community, it just never appears. It works fine with just text or links. Any idea why that is?

Can we install lemmy on cpanel?
I want to install lemmy on cpanel. The same way you install a forum. It's easy. Is it possible? I dont want to buy a whole server just for lemmy

how to block instances?
There are some Lemmy instances I'd rather not have on my All feed. I know I can block individual communities but can I block entire instances or do I need to host my own to do this?

Comments and posts not shown on Lemmy servers
Hey. I have issues when I comment posts, then sometimes it doesnt show up on the Lemmy server where the post was originally posted. Another issue is that if I try to make a post which contains a picture, then it doesnt work - only if it contains text only. What I do is that I tag the community, I want to post in. This is my Friendica account, but I have the same issues from my Mastodon account as well. Has anyone else had the same issues when interacting with Lemmy instances from other Fediverse platforms?

Urgent Warning: “Suspected Security bug” Edit : false alarm
So by complete luck I found a huge security bug in lemmy as far as I can understand. How can I test it with the team and disclose it with them? Edit: I thought it is weird that anyone can access lemmy.ml/setup but upon further investigation I found that no one can use it in anything other than the admins and that users can only signup a normal account from this page rather than admin account. Which means that this is a feature not a bug. overall I think admins should hide this page to future proof it from bugs.

lemmyBB: 502 Bad Gateway
I have a lemmy-ui instance working correctly, fresh ansible install. I haven't configured it yet, but it's up and running and test posts work fine. I'm mostly interested in lemmyBB, so I installed that according to "Alongside existing Lemmy instance (native)" install instructions. Everything seems to work fine during install, ```systemctl status lemmy_bb.service``` shows: ``` Jan 17 06:51:57 vps-f7b29755 lemmy_bb[484]: [2023-01-17T06:51:57Z INFO rocket::launch_] (FileServer: assets) GET /assets/<path..> [10] Jan 17 06:51:57 vps-f7b29755 lemmy_bb[484]: [2023-01-17T06:51:57Z INFO rocket::launch] 📡 Fairings: Jan 17 06:51:57 vps-f7b29755 lemmy_bb[484]: [2023-01-17T06:51:57Z INFO rocket::launch_] Templating (ignite, liftoff) Jan 17 06:51:57 vps-f7b29755 lemmy_bb[484]: [2023-01-17T06:51:57Z INFO rocket::launch_] Shield (liftoff, response, singleton) Jan 17 06:51:57 vps-f7b29755 lemmy_bb[484]: [2023-01-17T06:51:57Z INFO rocket::launch_] Site data fetcher (request) Jan 17 06:51:57 vps-f7b29755 lemmy_bb[484]: [2023-01-17T06:51:57Z INFO rocket::shield::shield] 🛡️ Shield: Jan 17 06:51:57 vps-f7b29755 lemmy_bb[484]: [2023-01-17T06:51:57Z INFO rocket_dyn_templates::fairing] 📐 Templating: Jan 17 06:51:57 vps-f7b29755 lemmy_bb[484]: [2023-01-17T06:51:57Z INFO rocket::launch] 🚀 Rocket has launched from ``` When checking in with a browser, I get 502 Bad Gateway. error.log ``` 2023/01/17 07:05:13 [error] 528#528: *33 connect() failed (111: Connection refused) while connecting to upstream, client:, server: forums.domain.com, request: "GET / HTTP/2.0"$2023/01/17 07:05:13 [error] 528#528: *33 connect() failed (111: Connection refused) while connecting to upstream, client:, server: forums.domain.com, request: "GET /favicon.ic$2023/01/17 07:05:32 [error] 528#528: *50 connect() failed (111: Connection refused) while connecting to upstream, client:, server: forums.domain.com, request: "GET / HTTP/2.0"$2023/01/17 07:05:32 [error] 528#528: *50 connect() failed (111: Connection refused) while connecting to upstream, client:, server: forums.domain.com, request: "GET /favicon.ic$ ```

How does lemmy federate communities?
When I follow a community remotely, its handle always mimicks that of a user. E.g, asklemmy is @asklemmy@lemmy.ml Does this imply that communities can reserve usernames? If not, how does Lemmy distinguish between users and communities remotely?

Can’t start pictrs
Hello, i had a problem with docker-log: my lemmy instance crashed and i went to see in the server how come and found that it is 100% occupied disk space. So I have deleted docker logs with: `sudo sh -c "truncate -s 0 /var/lib/docker/containers/**/*-json.log` and it works but now I can't see any images: https://feddit.it/pictrs/image/8246b865-e626-4d8e-9527-e298054f2370.png "error trying to connect: dns error: failed to lookup address information: Try again". I checked my config and it seems correct: `pictrs_url: "http://pictrs:8080"` I tried to restart pictrs and I have no error but when i execute `docker ps` it says: `"/sbin/tini -- /usr/…" 3 months ago Restarting (1) 13 seconds ago" as if it couldn't start.` I see many errors on docker-logs like: `lemmy_1 | Reqwest(reqwest::Error { kind: Request, url: Url { scheme: "http", cannot_be_a_base: false, username: "", password: None, host: Some(Domain("pictrs")), port: Some(8080), path: "/image/process.webp", query: Some("src=5c6125a2-1f94-445b-a1b1-52057c69a545.png&thumbnail=96"), fragment: None }, source: hyper::Error(Connect, ConnectError("dns error", Custom { kind: Uncategorized, error: "failed to lookup address information: Try again" })) })` I also add that on docker-logs i found this: on dockers-log i found also this: `pictrs_1 | 2023-01-12T12:12:23.710029Z WARN sled::pagecache::snapshot: empty/corrupt snapshot file found` `pictrs_1 | 2023-01-12T12:12:23.710213Z WARN sled::pagecache::snapshot: empty/corrupt snapshot file found` `pictrs_1 | Error: Error in DB, Read corrupted data at file offset None backtrace ()` `pictrs_1 |` `pictrs_1 | Caused by:` `pictrs_1 | Read corrupted data at file offset None backtrace ()` `fedditit_pictrs_1 exited with code 1` I have found that someone, in the past, have this same issue: https://lemmy.eus/post/3863 and https://lemmy.ml/post/696178 (but no one answer)

[SOLVED] Can I be logged in two accounts at once in the same instance
I want to keep my admin account and my normal everyday account separate, but I keep having to open an incognito window just to be able to login to a separate account without logging off from my first account.

Images not displaying on my instance
I ran out of space on my instance which is hosted on linode. I used their automated system to upgrade the node so it had more hard drive space. Since I did that, images have not displayed on my instance. Either from existing posts or new posts. How do I fix this? I submited a question on GitHub https://github.com/LemmyNet/lemmy/issues/2637 and was asked to provide a "the docker compose logs" and to try restarting "docker compose". I rebooted the virtual server, which I assume would restart the docker compose. If not, how do I restart it? Also can you give me the exact commands to: - do a docker compose restart and where I do it from - generate the docker compose logs and how to limit the size if it is likely to be to big to upload to github and where to run the commands from. Thanks in advance for your help.

[SOLVED] Changing instance URL (without federation)
Hello, all! I've just successfully installed a personal lemmy instance, but I did it under a temporary hostname. From what I've read in the docs, you *can't* change the domain name after you've started federating, but since I'm not enabling federation, I think I'm free to do it, but how do I go about actually changing the hostname? Is there a guide somewhere? Thank you

How to display a specific Lemmy post, in a <div>, on a page? (same server, same domain)
##### THE GOAL To display a specific Lemmy post (or just the comments component) in a `<div>` on a blog page. [`all blog pages`] and [`lemmy`] are in the same `/srv/` directory, served on the same domain. The ideal method would preserve Lemmy-UI's nested-comments, since they are already perfect. The purpose is: a Comments section for a blog, which brings people to the Lemmy forum. ** ##### ENVIRONMENT The [`lemmy instance`] and [`built-Hugo-pages`] are: - on a vps, in the same `/srv/` directory - served on the `same-domain` (no subdomain), by nginx. - The blog pages (hugo) are fully controlled. They are already running some JS scripts. - Lemmy is an ansible install (lemmy in `/srv/lemmy`. blog in `/srv/blog`). ** ##### THE QUESTION Is there a Direct way to display a specific Lemmy Post (or just the comments component) in a `<div>` on a page? ** ##### POSSIBLE IDEAS... Here are the ideas so far (if you have a better idea, I really want to know): ** ##### IDEA I - Inject the Lemmy Post-url at `<Router>`: 1 - Send the desired `Post-url` (or just the `/path`) to Lemmy from the blog (as a "string", via JS)... Maybe the `Post-url` (or `/path`) could be injected here, at `/server/index.tsx` ([line 165](https://github.com/LemmyNet/lemmy-ui/blob/main/src/server/index.tsx#L165)): ``` let isoData: IsoData = { path: req.path, site_res: site, routeData, }; const wrapper = ( <StaticRouter location={req.url} context={isoData}> <App /> </StaticRouter> ); if (context.url) { return res.redirect(context.url); } ``` Or perhaps the Post url (or /path) could be injected here, in `client/index.ts` ([at line 7](https://github.com/LemmyNet/lemmy-ui/blob/main/src/client/index.tsx#L7)): ``` const site = convertWindowJson(GetSiteResponse, window.isoData.site_res); initializeSite(site); const wrapper = ( <BrowserRouter> <App /> </BrowserRouter> ); hydrate(wrapper, document.getElementById("root")); ``` 2 - Now have Lemmy receive the path and display the Post (including the lemmy-UI), using `<blog-div>` as its window. Perhaps by changing the hydrate target from `("root")` to `("blog-div")` here: `hydrate(wrapper, document.getElementById("blog-div"));` 3 - Load the Lemmy CSS sheet, and any necessary JS <scripts>. ** ##### IDEA II - Intercept entire Lemmy Post string from server: 1 - In `/server/index.tsx` ([at line 187](https://github.com/LemmyNet/lemmy-ui/blob/main/src/server/index.tsx#L187))... Get the variable `const root = renderToString(wrapper);` - (which already contains the "inner HTML" for a specific Lemmy post) - currently injected in `res.send` at: `<div id='root'>${root}</div>` ([at line 231](https://github.com/LemmyNet/lemmy-ui/blob/main/src/server/index.tsx#L231)) 2 - Inject that root variable (the inner HTML for a specific Lemmy post) in the `<blog-div>`. 3 - Load the Lemmy CSS sheet, and any necessary JS <scripts>. ** ##### BACKUP PLAN 1 - Get data from Lemmy-JS-Client, Rebuild Comments UI 1 - Use the Lemmy-JS-Client to `GetPost` or `GetSite`. 2 - Then manually rebuild the nested-comments UI by injecting data from JSON objects (using html, js). Which could work, but I wonder if there's a more Direct way - since Lemmy already displays nested-comments perfectly. ** ##### BACKUP PLAN 2 - iFrame Just display the Comments page in an iFrame (and hide the navbar/sidebar). This is the laziest option. ** ##### DETERMINATION I've become a bit obsessed with this question (for months), because Lemmy displays 'nested-comments' perfectly, so it would be great to let Lemmy-UI render them. ** ##### THE QUESTION (TL;DR): Is there a Direct way to display a specific Lemmy Post (or comments component) in a `<blog-div>`? It seems possible - since [`all blog pages`] and [`lemmy`] are - in the same `/srv/` directory, and - served on the same domain An ideal method would utilize Lemmy-UI's nested-comments, since they are already perfect. I’m willing to attempt anything, if there might be a way...

  • Ada
  • 5M
Can’t subscribe to another lemmy instance
I am trying to follow this community on another lemmy instance, but I can't get it to turn up in search results on lemmy.ml. https://links.artemai.art/c/acrossthefediverse Am I doing something wrong, or is there an issue with federating with it for some reason?

Context button directs to 404
Not sure if this is something based on my browser (FF 107.0.1) or an issue from the actual button itself, but when I am hitting the context button from a notification it just sends me to a 404 page.

Latest Jerboa version from F-Droid crashes on start
Was working fine before.

How to create a post from an external fediverse account?
I see that I can comment on a post from an external account, and I also see that I can even make an external account a moderator in a community I administer. The question is, how can an external account create a post in a community it is subscribed to? Does that account have to create an account in the lemmy instance and login first?

  • suoko
  • edit-2
I have huge problems with my account
I got error 'you can't login cause you miss information' very often when I try to login via firefox Lemmur and chrome cannot login at all

Does lemmy planning to make an Android app?
Hello, folks. Basically question in title: maybe the app already in developing stage/any plans for timebeing? Thanks.

Friendica-Lemmy federation question
cross-posted from: https://lemmy.ml/post/607806 > This profile: https://forum.friendi.ca/profile/helpers > > Appears on lemmy as a remote community here: https://lemmy.ml/c/helpers@forum.friendi.ca > > ...which i found interesting because so far I've only seen lemmy be able to support remotely subscribing to peertube channels (and remote lemmy communities). > > However, when I put another friendica profile URL like https://forum.friendi.ca/profile/news in to the lemmy search box, it federates it as a remote user instead of a community: https://lemmy.ml/u/news@forum.friendi.ca > > Can anyone explain what is going on here? cc [@nutomic@lemmy.ml](https://lemmy.ml/u/nutomic) [@dessalines@lemmy.ml](https://lemmy.ml/u/dessalines)

Are we ever going to get better key-commands?
All I want is a way to finalize a post or comment without having to reach for the mouse. It's a little thing that's almost universally implemented. Just a simple Ctrl-Enter. That's all I'm asking for.

Can anybody point me in the right direction on why postgres would take this much CPU sometimes?
I noticed my Lemmy server's CPU sometimes spikes for unknown reasons. Here are some screenshots of the usage. It seems to be a postgres SELECT process and some parallel worker processes causing this. ![](https://midwest.social/pictrs/image/bb192745-b6ba-4ad4-8bf5-fecc798163f7.png) ![](https://midwest.social/pictrs/image/8fd03bf4-3602-429d-8f18-41060b24e4b2.png)

Unable to fetch posts on my instance from mastodon
I set up a mastodon instance and I'd like to interact with my lemmy instance (midwest.social) from it. Looking at the logs whenever I query a post, it returns a 200 OK with no data, but if I query a post on lemmy.ml it returns data like it should. I must have something configured wrong on my lemmy server. Here is the log for a query: ``` Error encountered while processing the incoming HTTP request: lemmy_server::root_span_builder: NotFound lemmy_1 | 0: lemmy_apub::http::post::get_apub_post lemmy_1 | at crates/apub/src/http/post.rs:20 lemmy_1 | 1: lemmy_server::root_span_builder::HTTP request lemmy_1 | with http.method=GET http.scheme="http" http.host=midwest.social http.target=/post/326295 otel.kind="server" request_id=1b0dce53-f66f-4f1d-9d6a-212de403f62a http.status_code=404 otel.status_code="OK" ```

Do markdown images work?
I'm trying to embed an image like `![](https://ibb.co/Dkq9h8L)` but it doesn't work. [Here](https://lemmy.ml/post/328152/comment/212429) [@cypherpunks@lemmy.ml](https://lemmy.ml/u/cypherpunks) says that it works.

How is the URL search option supposed to work?
When I [search for youtube.com](https://lemmy.ml/search/q/youtube.com/type/Url/sort/TopAll/listing_type/All/community_id/0/creator_id/0/page/1) with the URL option I expect to see every post with a youtube link but I get no results. So how am I supposed to use the URL search? How does it work?

Can I share a pict-rs installation between multiple Lemmy instances?
Would simplify the setup a bit if you host more that one Lemmy instance.

The image shows a 'onebox' or OpenGraph link preview generated when dropping this link https://lemmy.ml/post/569631 into a Discourse forum post. It would be very nice if the preview included the name of the Community to which this was posted, i.e. [!fediversefutures@lemmy.ml](https://lemmy.ml/c/fediversefutures)

Context not working
Using a browser. Every time I look at my inbox and click context underneath a comment, I get a 404. Any help would be appreciated.

Re-title a post?
Is there a way to change the title of a post someone else created on a community you moderate? If not, can we please add this functionality

[Solved] All ‘Save’ actions remain hanging
Since a little while all 'Save' actions hang on the spinner that keeps running. This while the save already happened. To see that I need to refresh the page. I had this with Create comment, Create cross-post, and soon I'll know if it happens with Create post too. Note that the refresh caused the cross-post not to be marked as such, and it looks like I duplicated a topic independently now.. [this post](https://lemmy.ml/post/539000) should be a cross-post of [this one](https://lemmy.ml/post/538538). Am using Firefox 105.0.3 on Ubuntu 22.04

Not receiving emails
I ticked the box for email notifications but I'm not getting any emails

context - button: 404 Page
If you click on the "context" button within https://feddit.de/c/kuketzblog, you basically get a 404 page. If you click this when the post was published from another community, it works. Do you know why?

Can’t upload images
Hey. I just installed a lemmy instance via YunoHost and I can't upload images. This includes an icon and banner for the instance. I get a SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

  • poVoq
  • edit-2
Webhook support?
Is there some sort of webhook support in Lemmy to automatically push new posts to a chat channel for example? I guess it could be done with a RSS feed bot, but doing it via webhooks would be nicer.

404: FetchError: invalid json response body at http://lemmy:8536/api/v3/user/replies?sort=New&unread_only=true&page=1&limit=20

Inconsistent comments
https://lemmy.ml/post/498512 vs https://feddit.de/post/387263/

    Create a post

    Support / questions about Lemmy.

    • 1 user online
    • 1 user / day
    • 1 user / week
    • 10 users / month
    • 45 users / 6 months
    • 1 subscriber
    • 129 Posts
    • Modlog
    A community of privacy and FOSS enthusiasts, run by Lemmy’s developers

    What is Lemmy.ml


    1. No bigotry - including racism, sexism, ableism, homophobia, transphobia, or xenophobia. Code of Conduct.
    2. Be respectful. Everyone should feel welcome here.
    3. No porn.
    4. No Ads / Spamming.

    Feel free to ask questions over in: